Skip to main content
shopping_basket Basket 0
Login

Can't install Spaceclaim Translators 19.1

I have followed the instructions to install Designspark Mechanical 

http://designspark.zendesk.com/hc/en-us/articles/360010645273

However everytime I try to install Translators it pops up a box "Can't install translators untill Spaceclaim is installed first. 

Any help appreciated.

Upvote 0 Votes
DesignSpark Electrical Logolinkedin