Skip to main content
shopping_basket Basket 0
Login

Boot on Raspberry Pi

Dear PI support,

I've  bought a Raspberry PI 3B+ from RS recently. I 've installed the latest Raspbian OS on a 32Gb MicroSD (Scan Disk SDHC Class 1). The first boot works fine and let me set up the system and use it if I want (I can do multiple reboot in cmd line, no issue). As soon as I power off the PI, it doesn't boot again: the red led is on, the green led blanks for a while then off. I've also tried using a retropie image;  I have the same issue: works the first boot then nothing.  The only way to make it work again is to rewrite the MicroSD (I am using Win32diskImager). Of course I've tried with another SD (Scandisk 64 Gb), but I have the same behaviour.

What I am missing ??!!??

Thanks in advance

Stephan 

0 Votes

Comments

November 23, 2019 10:05

Found out that it was not a booting issue after all (the led flashing sequence was nominal). It was just a display issue fixed by editing file /boot/config.txt and setting hdmi_force_hotplug = 1.
Still a mistery why the PI does not need this set-up at the very first boot.

0 Votes
VdH

November 19, 2019 13:22

Could you please try to either shut down the system before switching off the power or to remove the SD card before switching the power off? If the system then does boot a second time with the same SD card you are suffering from interrupted write cycles on the SD card during power down which might corrupt the SD content. You need to know that the Linux system does sometimes cache data before actually writing it on the disk. So directly disconnecting the power could interrupt such write cycles and depend on the system's parameters this could corrupt the disk content. Linux does have switches to make the system more immune against sudden power fails but they need to be set in the right way. Please refer to google search results for "linux prevent disk errors due to power fail"

0 Votes

November 23, 2019 10:05

@VdH Thanks for the advice. Spending more time on it , I find out that the PI is actually booting (looking at the led flashing on the board). So in order to solve my issue I 've just modify the /boot/config.txt file in order to force the HDMI video output : hdmi_force_hotplug = 1 (known issue for a while apparently). I still do not understand why the PI does not keed to force that parameter at the first boot …… But it works fine now. So not a booting issue but more a display issue …..

DesignSpark Electrical Logolinkedin