DesignSpark Electrical Logolinkedin
Menu Search
Ask a Question

Library Downloader not working

So today I downloaded Design Spark PCB (9.0).  One of the first things I wanted on my first project was an ATmega328p.  Since I couldn't find tis in the included libraries I followed the tutorial to create my own library then downloaded the "footprint" from RS components.  After extracting I found I had a DSL file.  This I used to manually add it into my own library.  This whole process worked fine.  I was able to use the schematic and pcb symbols without any issue.

Problems occured, however, when I then tried the same process for a crystal oscillator.  The "footprint" file downloaded was in an "EPW" file.  This I couldn't import.  I then downloaded "Library Downloader"  but after selecting my downloaded file it says "almost there you now have 3 choices"  and opens my browser on a window that has absolutely NOTHING to do with the part I've selected.  So I have to do the searching all over again?  I eventually gave up on this process and uninstalled Library downloader.  Would it be too much to ask for something that can convert these EPW files into the DSL format, that obviously works without any problem and requires no external application?

0 Votes

Comments

January 28, 2020 11:44

Can you post some pictures of the steps taken as have never seen that I am aware of the message "almost there you now have 3 choices". If at the RS site you get an EPW download it normally indicates the footprint is not available but it may be from library loader.
post the URL of the component at the search engine and the next steps you take.

BUT make sure you have launched DSPCB by a right click and run as admin, then close as this registers the OLE apparently which can then on further launches allow Library Loader and DSPCB to work together.

0 Votes