DesignSpark Electrical Logolinkedin
Menu Search
Ask a Question

Incompatible Gerber files

I am trying to make a simple pcb as my first design but having issues with companies that can produce the pcb.

If I create a simple rectangle using design spark it seems to get through the gerber checking process but I get these errors:

  • breakout with pads (Plot Report).txt(null): Non-gerber274X/excellon formats
  • breakout with pads - Bottom Copper (Paste).gbr(null): Non-gerber274X/excellon formats
  • breakout with pads - Bottom Copper.gbr(Bottom Layer):Gerber file with a board outline
  • breakout with pads - Documentation.gbr(null): Non-critical Gerber file
  • breakout with pads - Drill Ident Drawing - [Through Hole].gbr(drill chart): Non-critical

If I create a shape of a basic rectangle with 1mm rounded corners and export as 2d dxf into the board of pcb it all looks fine in pcb and can see 3d view but when uploading to the manufacture company they reject it saying there is legend in the copper layer on one company and a different company just does not show anything in the gerber viewer.

Is it me doing something wrong or  Is spark pcb not compatible or acceptable to these companys?

Thanks

 

0 Votes

Comments

August 16, 2019 07:18

This discussion is continued here
https://designspark.zendesk.com/hc/en-us/community/posts/360033754653-gerber-file-problems with some useful general comments.

0 Votes

August 13, 2019 07:40

As the errors are reported in the manufacturers file parser.
Read the required format and set up as previously mentioned.
Attached shows where to set the Gerbers and the button to press to ensure 274X.
Post any follow up in the forum, it makes discussion much easier.

0 Votes

August 12, 2019 07:18

these errors are seen on jlcpcb. The legned on copper layer is seen on pcbway.
In manufacturing output i dont see any option relating to 274x button

0 Votes

August 12, 2019 07:18

Where are you seeing these errors? Are you using a Gerber Viewer or an online tool? As all the errors report a Gerber274X issue, make sure you haven't accidentally selected the old 274D format for your files.
In the Manufacturing Output select and click the 274X button.

Also make sure each plot only has one layer enabled in it (except board outline which is commonly added to top copper).

If you are using an online viewer used by the manufacturer they will often specify the parameters they will accept and you must match your plots to meet their requirements.

If you can provide more details I will try to help, but post in the DSPCB forum where we can add images to aid discussions.
https://designspark.zendesk.com/hc/en-us/community/topics/200624545-DesignSpark-PCB-Discussion

0 Votes