Skip to main content
shopping_basket Basket 0
Login

After DS Electrical instalation the program do not want to activate when login my account. Keep giving a unknown error check all fields with * but all is correct?

Upvote 0 Votes

Comments

July 13, 2020 08:01

I have the same issue. The problem exists on 2 different computers I use. I tried the below recommendation with no luck. I am certain this is a DS issue on their server end, as both my computers "quit" working the same day. This is an older version of DS. I won't be migrating to the newer version; if I am going to be spending my money on a solidworks based system, I will just the the more powerful solidworks electrical.

0 Votes

July 2, 2020 16:51

Hi,
Try launching the program as an administrator and then login to your account. Enter your username and password instead of email id.

Best regards,
DesignSpark

0 Votes

June 29, 2020 14:38

When logging in, are you entering the email id or username? Try username if the email failed.
Also, do a password reset here and login with this new password: https://www.rs-online.com/designspark/password-reset/request

If none of those worked, create a new DesignSpark account with different email id here: https://www.rs-online.com/designspark/register

Then, login to the software with this new account.

0 Votes

July 13, 2020 08:01

@Joy Ch I am having the same issue as the poster. I have 2 different computers. I am sure it is a DS issue on the server end or something, as both my software installations (2 separate computers) worked fine until about 3 weeks ago.

DesignSpark Electrical Logolinkedin