Skip to main content
shopping_basket Basket 0

SMT Tracks and Pads


Can you please advise me or steer me in the right direction? I have ordered a dual mosfet, in an SOIC package type (part number 812-8233) from RS.

This is the first time I have tried to perform a PCB design using SMT components and my problem is that the tracks do not pick up the PADs. I have tried other SMT components, such as resisitors and those also cannot be selected when drawing tracks.

I cannot see anything in the settings and it is really vexing me.




0 Votes


April 19, 2021 08:43

Not sure exactly what you mean - maybe you are saying it isn't seeing the track path as complete when you end on what you think is the pad?

I'd check two things. Is the track on the same layer as the pad? It won't be connected if it is on the opposite surface of the board from the pad. ;-)

(On a single-sided board, through-hole components are usually on the opposite side of the board from the traces, while surface mount component need to be placed on the same side as the traces.)

The F key is a shortcut to flip a component to the opposite surface/side of the board. The L key is a shortcut to the change layer dialog to change between layers when drawing tracks/traces.

The other factor that could cause difficulty drawing traces to SMT pads is too large a grid setting when connecting fine-pitch components. To fix that, select Settings > Grids... from the menu, and set the grid size smaller or the snap to a smaller fraction of the grid.

0 Votes

April 19, 2021 08:43

@BradLevy Hi Brad, This is a little frustrating as this is the third time I have replied on this forum to your question, but they so not seem to be posting. Many thanks for your reply, it is appreciated. Ill try to explain in a different way. When I select "Add track", I cannot choose any of the pads on the SMT components. I can only add tracks or end tracks on through hole components. I had tried your two suggestions earlier and have just tried again, but alas they aren't the answer. I did wonder if I needed the pro version of the software, which I have downloaded the trial and installed, but that didn't fix it. Any other ideas? Regards, Christopher

April 19, 2021 08:43

@BradLevy A follow up to this, it is now solved thanks to John in Design Spark support. Within the Design Technology settings, I had set the "Top Copper" layer "Side" to be "Inner" instead of "Top". I must have changed this in the past and its only when now trying SMD work, it has shown itself. Thanks for replying in the first instance Brad.

[Comment was deleted]

[Comment was deleted]

DesignSpark Electrical Logolinkedin