Skip to main content
shopping_basket Basket 0

Latest installer just hangs on windows 10

Are there any  command line switches I can use to get logging information on what is causing the installer to hang? I've tried the latest version on a few machines running win 10 and it hangs at the same point on all of them.

The installer displays 'Installing DesignSpark Electrical' - 'Create Shortcut' and doesn't advance. All the systems I've tried this on are Spanish language Win 10 pro.


Is there any way to download an older version so I can let the users at least get on with their work?


May 17, 2021 08:11

I worked out the source of the problems after posting my question. The installer contains a couple of logic bugs. For some reason it executes the shell command 'net stop spooler', which will only work if you do not have any dependent services. However, pretty much everyone has pdf printers(pdf24 would be a good example), which depend on the spooler service. As a consequence the installer hangs as the shell command asks if you want to stop the dependent service and, naturally, its never going to get a response and so hangs.
The solution is to kill the process which is executing 'net stop spooler' and the installer continues without problems.
The real solution is to fix the installer. It should be executing 'net stop spooler /yes' or use a better method.

Even after installation there is a dependence on some tracing libraries which causes problems. DSE displays a library not registered error every time we open it, though it seems to work fine if we ignore the error. The only reference I could find in the forums says to register them using a combination of regasm and regsvr32.

These steps don't work and DSE displays an error every time we open it, though it seems to work. When I register the libraries I don't get any errors so the process seems to be ok and the libraries are not damaged or missing dependent components.

May 12, 2021 07:03


The DesignSpark Electrical installer is based on the 'installaware' toolkit. You can find info on logged execution here:

There is some help info on the issue you are facing with the installer freezing:

The earliest version we can offer for DSE is v2.0.0 (currently it is 2.0.1):

Best regards,
DSE Support

0 Votes
DesignSpark Electrical Logolinkedin