DesignSpark Electrical Logolinkedin
Menu Search
Ask a Question

How do i chamfer this extrusion?

Hi guys...

    i am more of a reader than of a writer.. but this time i must ask for help. So.. i have a problem that is making me scratching my head for the last couple of days.  This is a simple design that basically is a disc with a "fleur de lis" vector extruded at 1mm depth (it was imported as an .obj or .step from freecad.. which originally was an .svg). The thing is that i need to chamfer the extrusion because this is intended to be used as a pressure stamp and the chamfer really makes a difference.. but no matter how hard i try.. DSM is always telling me that this is a no-no!

Is important for me to say that i am just a newbie in CAD/CAM and although i do have experience in vector design.. CAD is still a new thing to me.. so this is most probable to be a missing step from my side..

So.. what am i doing wrong? :) I do know that DSM has the 0.1 chamfer limitation.. but this is not the case... well.. i really don't know what i am missing... any help? :)

 

Here is the source if anyone wants to look at it :

 http://www.joaocesarsilva.com/dsm/flor_de_lis.rsdoc

Here is the single spline version also with no chamfer :

http://www.joaocesarsilva.com/dsm/flor_de_lis_v2_spline.rsdoc

Kind regards,

Cesar

Comments

October 30, 2019 16:45

There are too many sharp thin corners in the model to create a chamfer. What you will need is a 'Draft Angle', this again will not work with the sharp corners.

What I have done in the attached model is smoothed the sharp corners on the solid.
Copied and pasted the top surface. Hide Solid. Moved the surface to 0,0,0 and 'Aligned' it with the 'Z' axis because it was not in line with it.
Created a Sketch Plane on the 'X Y' axis. 'Offset' all of the internal lines by 0.2mm and moved them to a new Layer. Turn off Layer 1. In 3D mode, select all lines and 'Fill'. 'Move' the surface up 1mm. Delete curves on layer 2. Turn on Layer 1. Select inside curves 'Fill' Delete curves.
Select both surfaces which should be 1mm apart and use the 'Pull' tool with the 'Blend' option.
Create the outer rim with it's center at the origin. Pull to thickness. Select shaped solid and 'Rotate' if it is upside down. Make sure both solids are in the correct position to use the 'Combine' tool to cut the shape from the disc.

0 Votes

October 30, 2019 16:45

@JACANT thank you so much for your kind explanation! This works great.. and is in fact a very ingenious way to bypass the sharp corner limitation on automatic chamfering. Maybe this is a standard thing to do.. but to me it is actually a new thing i have leaned thanks to you. Also.. fusion 360 has this limitation too.. i have tried it with the same results.. so i guess this is not DSM fault.. it's just how things are... :) Thank you so much... Cesar

October 31, 2019 11:35

@JACANT Thank you so much... that is in fact an ingenious way to solve this issue.. and it works like a charm!! :) Btw... Fusion 360 seems to also have this issue.. it will not chamfer sharp corners such as these.. (i have tried.. with same result).. so i guess this is not DSM fault as well.. it's just how things are...

October 30, 2019 16:46

I thought that thing be happening because the imported .obj would not have a single spline that was extruded on to the solid disc.. but.. i have designed the full spline and extruded it to the solid with the same result...

Single spline version in attachment...

0 Votes