The gateway to online resources and design support for engineers, powered by RS ComponentsAllied

+Post a new topic

Problem with v5.0, using "open with"

Avatar Posted by Ken Arton at

    Hello,

    I have just moved to Design Spark v5.0.
    It all works fine when I launch the program, then use the Menu - File - Open to open an existing design.
    But I like to just click on the .sch or .pcb filename and have it open. Windows 7 naturally does not recognize the file type, and asks me to select a program. I normally have no problem with this, and indeed with v4.1 there was no difficulty.
    But now when I browse to either the executable, or the desktop shortcut, for v5.0, and select "open", it does not add it to the list of Other Programs, and so I can't nominate it as the program to run. I think there must be an issue with v5.0, as I would have expected it to inherit the "open" behaviour from v4.1.

    Can anyone offer advice?
    Many thanks.

    Replies

    • Avatar

      Posted by MasterFX at

      Hi,
      I'm not able to reproduce you problem on my Win7 installation. In my case designspark appears in the "open with list" after I added it manually. I think it is more a Windows problem than a designspark problem. Or maybe there are some conflicts with other DS installations or so.

      But you can try the following.
      1. Open Regedit
      2. Got to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.sch\OpenWithList
      3. Right click on the right side => New => String Value
      4. Name the new String as a character which is not already in the list. In my case "c"
      5. Set the value to "designspark.exe"
      6. Edit the String "MRUList" and add you new created String name to the value of "MRUList", in my case is was "ab" and now it is "abc"

      win7Openlist.png
      win7Openlist.png (47.9 KiB) Viewed 757 times

    • Avatar

      Posted by Ken Arton at

      Hello,

      Many thanks for the prompt reply.

      I have tried your suggestion in regedit. In fact designspark.exe was already listed there, and on the MRUlist.
      Just to be sure, I added it again with a new letter, and added that to MRUlist,
      I also have tried setting designspark.exe as the default.
      The registry editor accepts all this, but it all makes no difference.
      I have of course re-booted just in case that is required.
      And finally I have completely removed and re-installed designspark v5.0.

      The problem remains.

      My experience with trying to get help from Microsoft forums is very poor, so I'm reluctant to go down that route.
      I guess I'll have to live with the inconvenience, or alternatively revert to v4.1.

      Anyway, many thanks for your help.

    • Avatar

      Posted by Unknown Source at

      I can't find a way to upload files but I have two programs that fixes this for you (unfortunately only tested on Win 7 32bit)

      Google two programs, one is called Unassoc.exe as you will want to unassociated the .prj files (and the other formats which I can't remember off the top of my head) first.

      Then find 'OpenWithAdd.exe' and add Design Spark.

      As mentioned above I would attach the programs but I can't see an option to....

      (both are made by some Indian fellow with a blog and forums so should be fairly easy to find)

      This option worked fine for me so hopefully it will everyone else :)

    • Avatar

      Posted by Unknown Source at

      Found a way to upload them!

      DS5Fix.zip
      (82.41 KiB) Downloaded 37 times

    • Avatar

      Posted by Unknown Source at

      Can't find a way to edit my posts above but here are full instructions of what I did....

      Run Unassoc.exe as admin
      Type .prj into the search box
      (to be safe) Click remove file association (User)
      Re-search for .prj
      Click delete file type
      Close the window.

      Run OpenWithAdd.exe as admin
      Click the three dots next to the search window and navigate to the DesignSpark V5.0 Folder
      Select Design Spark 5.0 from the window on the right
      Leave the Arguments window blank
      Enter what you wish the Program to be called (I entered DesignSpark V5.0) into the 'personalized name' box
      Click Register
      Close window.

      Navigate to a DesignSpark .prj file and double click (open with option should not be available yet as you have unassociated the file type in the first few steps).
      Select the option to manually select program
      Design Spark now appears as one of the Recommended Options
      Select it and ensure 'always open for this type of file' is ticked.

      JOB DONE

    • Avatar

      Posted by Ken Arton at

      Hello "Unknown Source",

      I have just read your three replies, after a long session trying without success to "fix corrupted user profile".
      It is now rather late, and I have had enough for today, so I will pursue your suggestions tomorrow.
      Many thanks for this -- I will let you know how I get on.
      Best regards. ken.

    • Avatar

      Posted by HomeGirl at

      @Ken Arton

      I had the same problem after upgrading to DSPCB 5.0.

      Took an hour to find out that it's easier to remove association by deleting extension from registry

      1. run regedit
      2. go to *HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts*
      3. find the .pcb and delete it.
      4. find the .sch and delete it
      5. close regedit

      now either
      (a) log off and on again or
      (b) close explorer.exe from task manager and restart it

      Now double click a .pcb or .sch file and associate with DSPCB

      Worked first time.

      HomeGirl

    • Avatar

      Posted by Ken Arton at

      Hello Again,

      I have just downloaded the two executables and followed your intructions.
      Took about 5 mins, and everything now behaves exactly as I wish.
      So simple, after hours spent trying to follow the advice from Microsoft Forum.

      Many thanks indeed, Ken.

    • Avatar

      Posted by zbb at

      There is a way to do that in Win7. This was mentioned in a MS forum:

      Quote
      In Windows 7 with IE 9 or Windows 8 with IE10

      Open your browser then go to Tools>>>Internet Options

      Then navigate to the Programs tab and click on the "Set Programs" button

      Then click on the "associate a file type or protocol with a program" blue link
      Unquote

      This forced dumbing down in Win7 by restricting the user made me go back to XP again on my machines.

    Post a reply